短线是银之家

 找回密码
 QQ注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 54258|回复: 60

[通达信] 短线是银主图公式(在11号上简单修改)

[复制链接]

2

主题

10

帖子

150

积分

钻石VIP

Rank: 6Rank: 6

积分
150

金牌VIP

QQ
发表于 2013-11-16 21:20:41 | 显示全部楼层 |阅读模式
一键分享 一键分享
  1. M60:=MA(C,60);
  2. M120:=MA(C,120);
  3. M240:=MA(C,240);
  4. DRAWBAND(M60,RGB(90,0,0),M120,RGB(0,90,0));
  5. DRAWBAND(MA(CLOSE,5),RGB(155,50,50),MA(CLOSE,20),RGB(83,123,68));
  6. {牛熊变线}
  7. 变线:=EMA(MA(CLOSE,30),5),LINETHICK0;{20 或 30 或 35}
  8. STICKLINE(C>=变线 AND C>=O,H,L,0,0),COLORRED;
  9. STICKLINE(C>=变线 AND C>=O,C,O,2.7,1),COLORRED;
  10. STICKLINE(C>变线 AND C<=O,H,L,0,1),COLORCYAN;
  11. STICKLINE(C>变线 AND C<=O,C,O,3,0),COLORCYAN;
  12. STICKLINE(C<变线 AND C<=O,H,L,0,1),COLORCYAN;
  13. STICKLINE(C<变线 AND C<=O,C,O,3,0),COLORCYAN;
  14. STICKLINE(C<变线 AND C<=O,H,L,0,1),COLORGRAY;
  15. STICKLINE(C<变线 AND C>O,H,L,0,1),COLORGRAY;
  16. STICKLINE(C<变线 AND C>O,C,O,3,1),COLORGRAY;
  17. STICKLINE(C<变线 AND C<=O,C,O,3,1),COLORGRAY;
  18. {分水岭操作线}
  19. PM:MA(C,5),COLORGRAY,LINETHICK1;{可用13}
  20. IF(PM<REF(PM,1),PM,DRAWNULL),COLORGRAY,LINETHICK0;
  21. IF(PM>=REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;
  22. IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;
  23. A:=MA(CLOSE,12)+ABS(MA(CLOSE,12)-REF(MA(CLOSE,12),1));{原公式为17,最终确定为12}
  24. B:=MA(CLOSE,12)+MA(CLOSE,12)-REF(MA(CLOSE,12),1);
  25. 分水岭:=IF(MA(CLOSE,12)<B,B,MA(CLOSE,12));
  26. 操作线:=分水岭-(EMA(C,3)-分水岭);
  27. AA:=CROSS(分水岭,操作线);
  28. STICKLINE(AA,C,O,3,0),COLOR0000AA;
  29. STICKLINE(AA,C,O,2,0),COLOR0033CC;
  30. STICKLINE(AA,C,O,1,0),COLOR0055EE;
  31. STICKLINE(AA,C,O,0.3,0),COLOR0099FF;
  32. STICKLINE(AA,H,L,0,1),COLOR0099FF;
  33. RR:=CROSS((MA(VOL,5)),(MA(VOL,10))) AND MA(C,2)>=MA(C,4); {AND VOL>=REF(VOL,1)}
  34. STICKLINE(RR,C,O,3,0),COLOR0000AA;
  35. STICKLINE(RR,C,O,2,0),COLOR0033CC;
  36. STICKLINE(RR,C,O,1,0),COLOR0055EE;
  37. STICKLINE(RR,C,O,0.3,0),COLOR0099EE;
  38. STICKLINE(RR,H,L,0,1),COLOR0099FF;
  39. MA5:MA(CLOSE,5),NODRAW;
  40. MA10:MA(CLOSE,10),COLORCC66FF;
  41. MA20:MA(CLOSE,20),COLORFFCC66,LINETHICK2;
  42. MA60:MA(CLOSE,60),COLOR00FF99,LINETHICK2;
  43. MA120:MA(C,120),COLORGRAY;
  44. MA240:MA(C,240),COLORBLUE;
  45. DRAWTEXT(CROSS(MA60,MA120),MA60,'牛'),COLORYELLOW,LINETHICK4;
  46. DRAWTEXT(CROSS(MA120,MA60),MA60,'熊'),COLORWHITE,LINETHICK2;
  47. 现价:PLOYLINE(1,CONST(C)),COLORBB0077,LINETHICK1;
  48. TY:=C;
  49. A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
  50. A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
  51. 前期高位:=REF(C,BARSLAST(HD)),COLOR00FF00,POINTDOT;
  52. STICKLINE(C,前期高位,前期高位,8,0),COLORYELLOW;
  53. 所属地域:DRAWTEXT_FIX(ISLASTBAR ,0.88,1,1,DYBLOCK),COLORYELLOW;
  54. 所属行业:DRAWTEXT_FIX(ISLASTBAR ,0.91,1,0,HYBLOCK),COLORYELLOW;
复制代码
和原11号公式增加了前期高位划线和版块行业地域显示,以下是对比图
修改后11号


正版11号



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?QQ注册

x
回复

使用道具 举报

0

主题

0

帖子

-220

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
-220
QQ
发表于 2013-11-16 21:20:46 | 显示全部楼层
看帖要回,回帖才健康,在踩踩,楼主辛苦了!
回复 支持 反对

使用道具 举报

5

主题

114

帖子

629

积分

高级会员

Rank: 4

积分
629
QQ
发表于 2013-11-16 22:51:09 | 显示全部楼层
看帖要回,回帖才健康,在踩踩,楼主辛苦了!
回复 支持 反对

使用道具 举报

5

主题

114

帖子

629

积分

高级会员

Rank: 4

积分
629
QQ
发表于 2013-11-16 22:56:12 | 显示全部楼层
短线是银主图公式效果图


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?QQ注册

x
回复 支持 反对

使用道具 举报

1

主题

160

帖子

1130

积分

钻石VIP

Rank: 6Rank: 6

积分
1130

最佳新人活跃会员

QQ
发表于 2013-11-17 15:04:10 | 显示全部楼层
啥也不说了,楼主就是给力!
回复 支持 反对

使用道具 举报

0

主题

51

帖子

271

积分

中级会员

Rank: 3Rank: 3

积分
271
QQ
发表于 2013-11-17 18:24:44 | 显示全部楼层
看了LZ的帖子,我只想说一句很好很强大!
回复 支持 反对

使用道具 举报

0

主题

2

帖子

10

积分

新手上路

Rank: 1

积分
10
QQ
发表于 2013-11-17 21:02:45 | 显示全部楼层
很好,很强大,怎么加到通达信系统里面?求教:lol
回复 支持 反对

使用道具 举报

0

主题

67

帖子

187

积分

注册会员

Rank: 2

积分
187
发表于 2013-11-18 21:31:18 | 显示全部楼层
谢谢楼主分享!
回复 支持 反对

使用道具 举报

1

主题

73

帖子

1925

积分

钻石VIP

Rank: 6Rank: 6

积分
1925
发表于 2013-11-20 07:15:34 | 显示全部楼层
学会做人,最重要的是要有民族文化的根基。
回复 支持 反对

使用道具 举报

1

主题

73

帖子

1925

积分

钻石VIP

Rank: 6Rank: 6

积分
1925
发表于 2013-11-20 09:31:26 | 显示全部楼层
逐字逐句地看完这个帖子以后,我的心久久不能平静,震撼啊!为什么会有如此好的帖子!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | QQ注册

本版积分规则

QQ|网站地图|手机版|小黑屋|短线是银之家 ( 浙ICP备06044894-4号 )  

GMT+8, 2018-7-17 02:05 , Processed in 0.156250 second(s), 31 queries .

☎短银之家服务热线:0571-81011800 论坛版本:X3

© 2013-2018 Dxsy008.com

快速回复 返回顶部 返回列表