短线是银之家

 找回密码
 QQ注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 5044|回复: 15

[通达信] 发一公式

[复制链接]

1

主题

20

帖子

2506

积分

金牌会员

Rank: 6Rank: 6

积分
2506
QQ
发表于 2014-11-25 13:20:50 | 显示全部楼层 |阅读模式
一键分享 一键分享
VAR1:=1.13;
VAR3:=LLV(HIGH,318);
VAR4:=100*(CLOSE-VAR3)/VAR3*VAR1;
VAR5:=REF(LLV(CLOSE,610),1)*VAR1;
VAR6:=REF(HHV(CLOSE,610),1)*VAR1;
VAR7:=100*(CLOSE-VAR5)/(VAR6-VAR5)*VAR1;
VAR8:=(CLOSE-LLV(CLOSE,880))/(HHV(CLOSE,880)-LLV(CLOSE,880))*100*VAR1;
VAR9:=(CLOSE-LLV(CLOSE,318))/(HHV(CLOSE,318)-LLV(CLOSE,318))*100*VAR1;
VARA:=(CLOSE-LLV(LOW,880))/(HHV(HIGH,880)-LLV(LOW,880))*100*VAR1;
VARB:=(CLOSE-LLV(LOW,318))/(HHV(HIGH,318)-LLV(LOW,318))*100*VAR1;
VARC:=EMA(100*(CLOSE-LLV(LOW,144))/(HHV(HIGH,144)-LLV(LOW,144)),5)/4*VAR1;
VARD:=IF(VARC>13.16,VARC,0)*VAR1;
VARE:=VARC<1*VAR1;
VARF:=VARD*VAR1;
VAR10:=VAR4<0 AND VAR7<0;
VAR11:=1;
VAR12:=(HIGH+LOW+CLOSE*2)/4*VAR11;
VAR13:=EMA(VAR12,34);
VAR14:=STD(VAR12,34);
VAR15:=((VAR12-VAR13)/VAR14*100+200)/4*VAR11;
VAR16:=(EMA(VAR15,89)-25)*1.56*VAR11;
VAR17:=EMA(VAR16,5)*1.22*VAR11;
VAR18:=EMA(VAR17,3)*VAR11;
VAR19:=3*VAR17-2*VAR18*VAR11;
VAR1A:=IF(CROSS(VAR19,VAR17) AND CROSS(VAR19,VAR18) AND CROSS(VAR17,VAR18),1,0);
VAR1B:=IF(CROSS(VAR17,VAR19) AND CROSS(VAR18,VAR19) AND CROSS(VAR18,VAR17),1,0);
买点
:= IF(FILTER(VAR8=0 AND VARE AND VAR10 AND VAR1A,5)=1,10,0);
卖点
:= IF(FILTER(VAR8=100 AND VARF AND VAR1B,5)=1,10,0);
VAR1C:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),13)/4*VAR1;
VAR1D:=EMA(CLOSE,2)-EMA(CLOSE,89)*VAR1;
VAR1E:=EMA(VAR1D,21)*VAR1;
VAR1F:=2*(VAR1D-VAR1E)*10*VAR1;
VAR20:=POW(VAR1F,3)*0.1+POW(VAR1F,2)*VAR1;
VAR21:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR22:=EMA(VAR21*0.97,3)*VAR1;
VAR23:=(HIGH+LOW+CLOSE)/3*VAR1;
VAR24:=(VAR23-MA(VAR23,14))/(0.015*AVEDEV(VAR23,14))*VAR1;
VAR25:=IF(VAR1F>0.013,VAR20,0)/34*VAR1;
拉升资金
: VAR25*5,COLORRED,LINETHICK2;
VAR26:=EMA(CLOSE,3)-EMA(CLOSE,144);
VAR27:=EMA(VAR26,55);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
VAR2A:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR2B:=EMA(VAR2A*0.97,3);
VAR2C:=(HIGH+LOW+CLOSE)/3;
VAR2D:=(VAR2C-MA(VAR2C,14))/(0.015*AVEDEV(VAR2C,14));
主力资金
: IF(VAR28>0.01,VAR29*200,-100),LINETHICK2,COLORYELLOW;
STICKLINE(VAR25>0,0,
拉升资金
,3,1),COLORRED;
STICKLINE(VAR25>0,0,
拉升资金
,0,0) ,COLOR0000FF;
STICKLINE(VAR25>0,0,
拉升资金
,3,0) ,COLOR000088;
STICKLINE(VAR25>0,0,
拉升资金
,2.6,0) ,COLOR000099;
STICKLINE(VAR25>0,0,
拉升资金
,2.2,0) ,COLOR0000AA;
STICKLINE(VAR25>0,0,
拉升资金
,1.8,0) ,COLOR0000BB;
STICKLINE(VAR25>0,0,
拉升资金
,1.4,0) ,COLOR0000CC;
STICKLINE(VAR25>0,0,
拉升资金
,1,0) ,COLOR0000DD;
STICKLINE(VAR25>0,0,
拉升资金
,0.6,0) ,COLOR0000EE;
STICKLINE(VAR25>0,0,
拉升资金
,0.2,0) ,COLOR0000FF;
N1:=13;
N2:=5;
MTM:=C-REF(C,1);
ZLGJ:=MA(100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1),2),COLORWHITE;
MAZL:=MA(MA(ZLGJ,N2),3),COLORYELLOW;
DRAWICON(CROSS(ZLGJ,MAZL) AND MA(C,5)>=REF(MA(C,5),1) AND MA(C,2)>=REF(MA(C,2),1),MA(
拉升资金
,5),9);
DRAWICON(CROSS(MAZL,ZLGJ) AND MA(C,5)<REF(MA(C,5),1) ,MA(
拉升资金
,5),2);
A1:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100;
BL:=VOL/CAPITAL*100;
STICKLINE(A1>=0,0,A1*50,0,0 ),COLOR00008A;
STICKLINE(A1>=0,0,A1*50,2.2,0 ),COLOR00889A;
STICKLINE(A1>=0,0,A1*50,1.9,0 ),COLOR0099AA;
STICKLINE(A1>=0,0,A1*50,1.6,0 ),COLOR00AABA;
STICKLINE(A1>=0,0,A1*50,1.3,0 ),COLOR00BBCA;
STICKLINE(A1>=0,0,A1*50,1,0 ),COLOR00CCDA;
STICKLINE(A1>=0,0,A1*50,0.7,0 ),COLOR00DDEA;
STICKLINE(A1>=0,0,A1*50,0.4,0 ),COLOR00EEFA;
STICKLINE(A1>=0,0,A1*50,0.1,0 ),COLOR00FFFF;
A1Q:=34;
实体比例
:=(CLOSE-OPEN)/REF(CLOSE,1);
冲击系数:=MA(实体比例
,A1Q),COLORRED;
回头线:=MA(MA(冲击系数
,2),2),COLORYELLOW;
DRAWICON(CROSS(
冲击系数,回头线) AND MA(C,5)>=REF(MA(C,5),1) ,MA(拉升资金
,5),1);
红色拉升资金:0,COLORRED;黄色主力资金:0;

回复

使用道具 举报

0

主题

0

帖子

-220

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
-220
QQ
发表于 2014-11-25 13:21:18 | 显示全部楼层
纵横网络BBS多年,自以为再也不会有任何帖子能打动我,没想到今天看到了如此精妙绝伦的这样一篇帖子!楼主,是你让我深深地理解了“人外有人,天外有天”这句话。谢谢侬!
回复 支持 反对

使用道具 举报

57

主题

245

帖子

2147

积分

实习版主

Rank: 7Rank: 7Rank: 7

积分
2147
QQ
发表于 2014-11-25 21:17:03 | 显示全部楼层
太好了,非常棒
回复 支持 反对

使用道具 举报

0

主题

16

帖子

72

积分

注册会员

Rank: 2

积分
72
发表于 2015-1-23 16:56:21 | 显示全部楼层
看帖看完了至少要顶一下,还可以加入到淘帖哦!
回复 支持 反对

使用道具 举报

0

主题

11

帖子

55

积分

注册会员

Rank: 2

积分
55
发表于 2015-2-6 13:51:06 | 显示全部楼层
太棒了,谢谢!
回复 支持 反对

使用道具 举报

57

主题

245

帖子

2147

积分

实习版主

Rank: 7Rank: 7Rank: 7

积分
2147
QQ
发表于 2015-2-6 20:16:18 | 显示全部楼层

纵横网络BBS多年,自以为再也不会有任何帖子能打动我,没想到今天看到了如此精妙绝伦的这样一篇帖子!楼主,是你让我深深地理解了“人外有人,天外有天”这句话。谢谢侬!
回复 支持 反对

使用道具 举报

0

主题

15

帖子

67

积分

注册会员

Rank: 2

积分
67
QQ
发表于 2015-5-30 03:05:39 | 显示全部楼层
果断回帖,如果沉了就是我弄沉的很有成就感
回复 支持 反对

使用道具 举报

4

主题

422

帖子

1126

积分

金牌会员

Rank: 6Rank: 6

积分
1126
QQ
发表于 2016-6-24 22:55:34 | 显示全部楼层
纵横网络BBS多年,自以为再也不会有任何帖子能打动我,没想到今天看到了如此精妙绝伦的这样一篇帖子!楼主,是你让我深深地理解了“人外有人,天外有天”这句话。谢谢侬!
回复 支持 反对

使用道具 举报

4

主题

422

帖子

1126

积分

金牌会员

Rank: 6Rank: 6

积分
1126
QQ
发表于 2016-6-24 22:56:00 | 显示全部楼层

纵横网络BBS多年,自以为再也不会有任何帖子能打动我,没想到今天看到了如此精妙绝伦的这样一篇帖子!楼主,是你让我深深地理解了“人外有人,天外有天”这句话。谢谢侬!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | QQ注册

本版积分规则

QQ|网站地图|手机版|小黑屋|短线是银之家 ( 浙ICP备06044894-4号 )  

GMT+8, 2018-5-26 21:49 , Processed in 0.093750 second(s), 30 queries .

☎短银之家服务热线:0571-81011800 论坛版本:X3

© 2013-2018 Dxsy008.com

快速回复 返回顶部 返回列表